Rate limit exceeded. Slow down cowboy - using a APIKEY

View previous topic View next topic Go down

Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  ctjimmy on Fri Jun 13, 2014 8:39 am

Due to the number of times I've seen this message recently, and the fact that I have my own APIKEY, is there a way to use a person APIkey instead of the one built into comictagger so that the above messages doesn't show. Apparently it's been set up so that only 200 requests in a 15 minute period are allowed per APIKEY to get more people to get their own ones.

Thanks,
Jimmy

ctjimmy

Posts : 9
Join date : 2013-03-28

View user profile

Back to top Go down

Re: Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  ctjimmy on Fri Jun 13, 2014 8:42 am

Can't believe it.  Sheer seconds after positing my message I've found a way of doing this for the command line version.  I don't know if it works for the GUI.  Someone more familiar can maybe let me know.

in ~/.Comictagger/settings there is a section that starts:
[comicvine]

In that, I've added the line:

cv_api_key = My-API-KEY-FROM-COMICVINE

and I no longer get the error message.

It would be great if this was something that could be set via the preferences window as well.

Having said that, I don't want to come across as 'take, take, take' and really appreciate the work put into this  code.

Jimmy

ctjimmy

Posts : 9
Join date : 2013-03-28

View user profile

Back to top Go down

Re: Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  ComicTagger on Sat Jun 14, 2014 12:06 pm

Sounds like you have been updating directly from the SVN repository. You should be careful as there is no guarantee you'll not get a broken version when you do that.

Version 1.1.5-beta is released, and has what you asked for.
avatar
ComicTagger
Admin

Posts : 208
Join date : 2012-12-02

View user profile http://comictagger.forumotion.com

Back to top Go down

Re: Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  ctjimmy on Mon Jun 16, 2014 11:56 am

I came across the error, and then downloaded the SVN repo to see if there were any hints in there which is where I got the information from. I was still using the 1.14 version, but added the extra line.

Anyhow, thanks very much for creating beat 15 and I'll look into that to fix my problem.

Jimmy

ctjimmy

Posts : 9
Join date : 2013-03-28

View user profile

Back to top Go down

Re: Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  anomander on Sat Sep 13, 2014 5:47 pm

If you hit this limit CT stalls and you have no option but to cancel. That is fine except you lose every match already made during that matching session.

Ideally matches would still be applied just as if you had come to the end of the session as normal.
avatar
anomander

Posts : 74
Join date : 2013-03-28

View user profile

Back to top Go down

Re: Rate limit exceeded. Slow down cowboy - using a APIKEY

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum